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Preface

Audience

This document is your primary source of introductory and usage information for Oracle Rdb
Developer Tools for Visual Studio.

This preface contains these topics:

. Audience

. Organization

. Related Documentation
. Conventions

Oracle Rdb Developer Tools for Visual Studio Developer’s Guide is intended for developers who are
developing applications to access an Oracle Rdb database using Oracle Rdb Data Provider for .NET.
This documentation is also valuable to systems analysts, project managers, and others interested in the
development of database applications.

To use this document, you must be familiar with Microsoft .NET Framework classes and ADO.NET
and have a working knowledge of application programming using Microsoft C#, Visual Basic, or C++.

Users should also be familiar with the use of Structured Query Language (SQL) to access information
in relational database systems.



Organization

This document contains:

° Chapter 1, Introducing Oracle Rdb Developer Tools for Visual Studio.
Provides an overview of Oracle Rdb Developer Tools for Visual Studio.
° Chapter 2, Installing Oracle Rdb .NET Products

Describes how to install Oracle Rdb Data Provider for .NET and provides system
requirements. Read this chapter before installing or using Oracle Rdb Developer Tools for
Visual Studio.

° Chapter 3, Using Oracle Rdb Developer Tools for Visual Studio
Describes how to create a database connection using ORDP.NET within Visual Studio.

° Chapter 4, Building a Simple .NET Application Using ORDP.NET
Provides an example on how you may build a simple application with database access using
ORDP.NET.

° Chapter 5, Retrieving and Updating with ORDP.NET
Provides an example of data retrieval and update using the features of Visual Studio and data
access using ORDP.NET.

° Chapter 6, ORDP.NET and Visual Studio Wizards
Provides an example on using standard Visual Studio wizards to automatically generate the
code to access data from your Rdb database.

° Chapter 7, ORDP.NET and drag and drop
Provides an example of using the drag and drop features of Visual Studio to generate code for
your application.

° Chapter 8, Configuration wizard and generating gueries
Provides an example of using Table Adapter Query Configuration Wizard to generate queries
on your database.

° Chapter 9, Copying a Form
Describes how to copy a form as required when following the examples provided in this
document.

° Chapter 10. Oracle Rdb Entity Framework Provider

Describes how to use ORDP.NET within the Entity Framework using standard Entity
Framework tools and features of Visual Studio.

° Chapter 11. Unsupported features
Specifies what Visual Studio features are currently not supported by ORDT.
° Glossary

Defines terms used in this document.

Related Documentation

For more information, see these Oracle Rdb resources:

. Oracle Rdb7 Guide to Database Design and Definition

. Oracle Rdb7 Guide to Database Performance and Tuning

. Oracle Rdb Introduction to SQL

. Oracle Rdb 7.2 SQL Reference Manual

. Oracle Rdb Guide to SQL Programming

. Oracle SQL/Services Server Configuration Guide

. Guide to Using the Oracle Rdb7 Oracle SQL/Services (tm) Client API
. Oracle Rdb JDBC Driver Users Guide

To download free release notes, installation documentation, white papers, or other collateral, please
visit the Oracle Rdb web site:



http://www.oracle.com/technetwork/database/rdb

For additional information, see:
http://msdn.microsoft.com/netframework

Conventions
Oracle Rdb Data Provider for .NET is often referred to as ORDP.NET.
Oracle Rdb is often referred to as Rdb.
Hewlett-Packard Company is often referred to as HP.

The following conventions are used in this document:

word (A lowercase word in a format example indicates a syntax element that you supply.
[1 |Brackets enclose optional clauses from which you can choose one or none.
{} |Braces enclose clauses from which you must choose one alternative.

A horizontal ellipsis means you can repeat the previous item

A vertical ellipsis in an example means that information not directly related to the example has been
omitted.

Conventions in Code Examples
Code examples illustrate SQL or other command-line statements. They are displayed in a monospace

(fixed-width) font and separated from normal text as shown in this example:

SELECT last name FROM employees WHERE last name = 'TOLIVER';

Showe Mavigation |


http://www.oracle.com/technetwork/database/rdb
http://msdn.microsoft.com/netframework

Chapter 1
Introducing Oracle Rdb Developer Tools for
Visual Studio.

Oracle Rdb Developer Tools for Visual Studio (ORDT) is a set of application
tools that integrate with the Visual Studio environment. These tools provide
graphical user interface access to Oracle Rdb functionality, enable the user to
perform a wide range of application development tasks, and improve
development productivity and ease of use.

ORDT includes:
e Oracle Rdb Data Provider for .NET ( ORDP.NET).

A standard .NET Data Provider that allows access to Oracle Rdb databases
from the .NET environment

e Oracle Rdb DDEX Provider.

A standard .NET DDEX provider that integrates ORDP.NET functionality
into Visual Studio.

e Oracle Rdb Entity Framework Provider.

A standard .NET Entity Framework provider that integrates ORDP.NET
functionality into Entity Framework.

Chapter 2 Installing Oracle Rdb .NET
Products

See the Oracle Rdb Developer Tools for Visual Studio Release Notes for information on how
to install Oracle Rdb .NET products.

Show Mavigation |



Chapter 3 Using Oracle Rdb Developer
Tools for Visual Studio

This chapter contains:

o Using Oracle Rdb Developer Tools
o Connecting to the Oracle Rdb Database

3.1 Using Oracle Rdb Developer Tools

Oracle Rdb Developer Tools for Visual Studio (ORDT) is a tightly integrated
Add-in for Visual Studio. Using enhancements that ORDT brings to the Server
Explorer, you can automatically create tables, indexes, constraints, data
connections and other database schema objects. Additionally you can
automatically generate application code.

3.2 Connecting to the Oracle Rdb Database

This section shows you how to use the Server Explorer to connect to the
Oracle Rdb Database for the purpose of automatically creating or modifying
database schema objects.

To connect to the database:
Stepl: From the View menu, select Server Explorer.

Step2: In Server Explorer, right-click Data Connections.
Step3: Select Add Connection.

Server Explorer

2] ¢ | 13, i
Data Connectionsl

T4 Servers #] Refresh

+
¥
f

Add Cannection, .. [‘_;;

Create Mew SOL Server Database. .




Step4: When the Add Connection window appears, determine if the Data
source says Oracle Rdb Database (RdbClient).

If it does, skip to Step 6.

Add Connection @

Enter information ko connect ko the selected data source ar click
"“hange" to choose a different data source andfor provider.

[Daka source:

If Data source does not say Oracle Rdb Database (RdbClient), select Change.

The Change Data Source window appears.

Change Data Source @

[aka source:

Microsoft Access Database File % Description

Microsoft SDEC Data Source MET Framewark Daka Provider For Oradle
Microsoft S0L Server 2005 Compact Edition Rdb

Microsaft SQL Server Database File

Oracle Database

COracle Rdb Database
<other=

Data provider:

MET Framework Daka Provider For Oracle »

[ ahways use this selection OF l [ Cancel

Step5: Choose Oracle Rdb Database and then select .NET Framework Data

Provider For Oracle Rdb.
Step6: On the Connection Details tab, in the Add Connection window, enter
the following information:

To connect to a database using a SQL/Services universal service:

For Server, enter the node address and a valid SQL/Services service that will
be running on the selected node. Remember to separate the node address
and service name with a colon (:). In this example we assume that a
universal service called GENERIC is running on the selected node.

The node address must be valid TCP/IP node specification.



For User name, enter a valid username for the database you will select.
For Password, enter the password for that user
To save the password for future sessions, check the Save password box.

For Database name, Enter a valid database file specification. Depending on
the setup of SQL/Services on the server node, this database specification may
include device and directory information as well as the database filename and
may use OpenVMS logical names.

The Connection name should be generated automatically from the
Database name.

Add Connection @@

Enter information to conneck to the selected data source or
click "Change" to choose a different data source andfor
provider,

Daka source:

Cracle Rdb Database (RdbClient)

Server (name: <port o service=):

my _sg5_server GENERIC

[] Use Thin Server

User name:  |rdbnet_user

Password: [ITTIITIITT]

Save my password

Database name:
disk1:[M¥_TEST DATABASESIMF_PERSCMMEL|

[ Tesk Connection l I Ikl l [ Cancel ]

To connect to a database using a SQL/Services database service:

For Server, enter the node address and a valid SQL/Services database service
that will be running on the selected node. Remember to separate the node
address and service name with a colon (:).

In this example we assume that a database service called MF_PERS is
running on the selected node.

The node address must be valid TCP/IP node specification.
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For User name, enter a valid username for the database you will select.
For Password, enter the password for that user
To save the password for future sessions, check the Save password box.

Leave the Database name blank as this is not required when a database
service is used.

The Connection name should be generated automatically from the Database
name.

Add Connection @@

Enter information to connect ko the selected data source or
click "Change” to choose a different data source andfor
provider.

Drata source:

Oracle Rdb Database {(RdbClient)

Server (name: <port or service>):
my_sqs_server:MF_PERS

[] Use Thin Server

User name:  |rdbnet_user

Passwaord: ITTTTIIT L

Save my password

Database name:

[ Test Connection ] I Ok l ’ Cancel ]

Step7: Click Test connection.

r

al
Microsoft Visual Studio E|

"
y Test connection succeeded,

The test should succeed. Click OK.

If the test fails, it may be due to one or more of the following issues that you
must address before proceeding with further steps:

11



o The database listener or server is not started.
The database connectivity is not properly configured.
o You do not have the correct user name, or password.

Step8: In the Add Connection window, click OK.

Step9: In the Server Explorer, expand the database connection to show the
contents of the database . You should see Tables, Views, Procedures,
Functions, Packages, Synonyms, Sequences, and so on.

__1’; Start Page - Microsoft Visual Studio
File Edit View Tools ‘Window Community Help

i - e ol | & Ea

Server Explorer

OGO | 3,

ERMETEO::= Connections
= ._'J;-userl:[my_test_databases]mF_Personnel
Tables
&('\] Yiews
EQ Domains
Eﬁl SYNonyms
BN Procedures
3 Functions
T Outlines
= 54 Servers
& jmurray-au

=3 e R R R
ol
(]
o
im)
[y
o
)
a
o
i

Show Mavigation |
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Chapter 4 Building a Simple .NET
Application Using ORDP.NET

This chapter contains:

o Creating a New Project

o Adding a Reference

o Adding Namespace Directives

o Designing the User Interface

e Writing the Connection Code

o Compiling and Running the Application
o Error Handling

4.1 Creating a New Project

Visual Studio groups all development code that you create into containers
known as projects. Simpler projects often contain only one file. In this section,
you will learn how to create a new development project.

The application you build in this chapter serves as a starting point for work in
subsequent chapters, so it is important to follow the order of this guide.

Note:
When necessary, instructions specify Visual C# or Visual Basic.

To start a new project:
Stepl: Start Visual Studio.

Open the Start menu, select All Programs, and then select Microsoft Visual Studio
2005.

13



0 Start Page - Microsoft Visual Studio

File Edit Wiew Tools ‘Window Community  Help

R == W - N e W I R N 2 -]

| statpage  _xk
] , =
g i 3 Microsoft

o Visual Studio 2005
MSDH: isual C#

BEET “LING to SQL Dverview'

Wed, 19 Mar 2008 15:03:52 -0700 - Luca Bolegnese's presentation on |
LING at the Tech Ed. =

Video of Luke Hoban's In-Depth Look at C# 3.0

Mon, 25 Feb 2008 17:00:21 -0800 - Last Fall in Barcelona, Spain bwa
Pi's From the C# keam gawe talks on key parts of the new LING

\, i
= technology Found in Wisual Studio 2008,
Getting Started
Heroes Happen Here

e —
" video

Lol

pen: Project...  |wieh Site...
Create: Project...  |wieh Site...

What's new in C# 20057 Wed, 27 Feb 2008 10:05:10 -0800 - Welcome to the launch of Windows
Create Your First Application Server 2008, Yisual Studio 2008 and SQL Server 2008, Together these
Use a Starter Kit three products provide a secure and trusted platform For building your
HowDal.. ? mosk mission-critical applications. Learn more about these products and
Learn Yisual C# launch ewenks in your area st HerossHappenHere.com,

Connect With the Cammurity Why Do Initializers Run In The Dpposite Order As Constructo...
Download Additional Content Wed, 19 Mar 2008 15:04:27 -0700 - Learn about the order in which
constructors are called in class hierarchies that use inheritance.

Why Do Initializers Run In The Opposite Order As Constructo...

Wed, 19 Mar 2008 15:03:58 -0700 - Learn more about the order in
which constructors are called in class hierarchies that use inheritance,

Community Convergence XLI

\ J
)
< B
Error List * 1 X

Description File Line | Column Project

The Microsoft Visual Studio IDE environment appears.

Step2: In the Start Page, under the Recent Projects heading, click Create:
Project.

Alternatively, from the File menu, select New, and then select Project.
A New Project dialog box appears.

Step3: In Project Types, select the type of project you are creating:
Visual C#:
Visual C#: Windows
Visual Basic:
Other Languages: Visual Basic: Windows

Step4: In Templates, select Windows Forms Application.
Step5: In the Name field, enter the appropriate name.

Visual C#:

PERS Connect CS

14



Visual Basic:

PERS Connect VB

The abbreviation CS indicates C# projects and VB indicates Visual Basic
projects.

Step6: In Location, enter the directory where you want to save the files.
For this guide, enter this directory C: \PERS Projects.

Step7: In Solution Name, the appropriate name, PERS_Connect_CS or
PERS_Connect_VB should appear.

A solution can contain several projects; when it contains only one project, you
can use the same name for both.

Step8: Check Create directory for solution.
Step9: Click OK.

Project types: Templates: ‘|
B visual C# Yisual Studio installed templates
B indaws o
- Smart Device (FFwindaws Application {ER Class Library
-~ Database [ windaws Contral Library «ZFlweb Control Library
- Starker Kits ._3 Consale Application EWmdows Service
“Weh [F]Empty Project ECrvstal Reports Application
Wik
- Other Languages My Templates
=~ Other Project Types
- Setup and Deployment ,j Search Online Templates...
-~ Database
Extensibility
- Wisual Studio Solutions
A project For creating an application with a Windows user interface
Mame: ‘ PERS_Connect_C5 |
Location: ‘ CHPERS_ . | [ Browse... ]
Solution Mame: ‘ PERS_Connect_CS ‘ Create directary Far solution

The project is created.

The main window now displays a new title, either PERS_Connect_CS -
Microsoft Visual Studio or PERS_Connect_CS - Microsoft Visual
Studio, depending on the language, and contains Form1 shown below.

It is important to remember that many projects automatically name the first
form Form1. This is the name of the form control. Do not confuse this with
the actual name given to the code file, which is typically Forml.cs or
Forml.vb.

15



Both Form1l and Forml . xx can be renamed. For the purposes of this guide,
we will rename Forml . xx several times.

Forml.cs [Design]  Start Page = &8

4.2 Adding a Reference

This section shows you how to add a reference to the
Oracle.DataAccess.Rdb.dl1 file, which contains the data provider,

Oracle Rdb Data Provider for .NET.

To add a reference:

Stepl: From the Project menu, select Add Reference.

Project | Build Debug Data Format

Add Windows Form...

5]
8 Add User Contral...
] Add Component...
2 Add Class... Shift+alk+C
sii| Add Mew Item... Chrl+Shift+4
:i:| Add Existing Ttem...  Shift+al+a
Exclude From Project
A Show All Files
Add Reference. ..
Add Wweb Reference...
Set as StartUp Project
Project Dependencies. ..

Project Build Crder...

PERS_Connect_CS Properties, ..

The Add Reference windows appears.



Step2: In the Add Reference window, under the .NET tab, select
Oracle.DataAccess.Rdb Click OK.

Add Reference EWE

MET | CoM | Projects || Browse | Recent

Component Mame ‘ersion Runtime Path ~
Microsoft. Windows Desi... 3.5.0.0 v2,0.50727 C\Program Filesi\Micra,
Microsoft. Windows Desi... 3.5.0.0 v2,0.50727 C\Program Filesi\Micra,
IMicrosoft_Ysavh 4.0.0.0 ¥2.0.50727  CYWINDOWSMicrosof .
MSCOMCTL 10.0.450... w1.0.3705  C:\Program Files\Micro,
MSCOMCTL 10.0.450... w1.0.3705  C:\Program Files\Micro,
mscorlib 2.0.0.0 ¥2.0.50727  C\WINDOWSMicrosof .
msdatasrc 7.0,3300.0 +1.0.3705  C:\Program Files\Micra,
msdatasrc 7.0,3300.0 +1.0.3705  C:\Program Files\Micro.
msdatasrc 7.0,3300.0 +1.0.3705  C:\Program Files\Micro.
Office 11.0.0.0 v1,1.4322  C\Program Files\Micro,

Office 12,0.0.0 v1,1.4322  C:\Program Files\Micro,
Or achpDatasccess Rdb 3.1.0 : 727 Ci\Program FilesiOracl,

[, 27
Oracl db.¥sDevTools 1.0.0.0 v2.0.50727 C:\Program Files\Oracl,

PresentationBuildTasks 3.0.0.0 ¥2.0.50727 C:\Program Files\Refer.
Presrrbatinnd nre 3000 WA NLENFA?  CAPranram FilesiRefer,
»
[ Ok ] [ Cancel ]

Note that the new reference appears in the Solution Explorer.

Solution Explorer - PERS_Connect_C5

= | & F A
_: Salution 'PERS_Connect_CS' {1 project)

Bl Trirs Comnet 5 ]

=d| Properties

= | References
-3 Oracle.Datasccess kb
< System
<3 System.Data
0 System.Deployment
-3 System.Drawing
- System.Windows Forms
2 System.zml

=] Forml.cs

Cﬁ Program.cs

4.3 Adding Namespace Directives

You can add Oracle namespace directives that allow you to indicate an
assembly's namespaces within the module. To do this, add C# using
statements or Visual Basic Imports statements, at or near the top of a code
file.

Note:
Adding a reference makes the namespace available within the
application. Adding a namespace directive within the application code
makes the namespace more visible and allows for additional scoping.

17



To add Oracle Rdb namespace directives:
Stepl: With Form1 active, from the View menu select Code.

Alternatively, you can use the F7 keyboard shortcut.

Miew | Project  Buld  Debug
[Z] Code F7
=] Designer Shift+F7

T5 Server Explorer  Chrl+w, L
.:j Solution Explorer Chrl+w, S

T Class View Chrl+w, ©

Step2:  Add the following statements to the list of declarations depending on
the language you are using.

Visual C#:

Add with other using statements, before the namespace.

using Oracle.DataAccess.RdbClient;

Y Forml.cs*|” Forml.cs [Designl* | Start Page

ve the caret ta the next bookmark, (Cer4+B, N)| Py
TF

Fusing System:
using Jystem.Collections. Generic;
using System.ComponentModel;
using Svstew.Datar
using 3ystem.Drawing;
using 3ystem.Text:
using Jystem.Windows.Forms;
using Qracle.Datalocess.RdbClient)

Visual Basic:

Add to the top of the file, in the declarations section.

Imports Oracle.DataAccess.RdbClient

18



rml.¥vb* | Forml.wb [Design]* | Forml.cs*
J:j(ﬁeneralj W J;](Declaratiuns)

Imports Oracle.Datalcocess.RBdhClient
F Public Class Forml

LEnd Class

Step3: Save the changes by selecting Save from the File menu, or using the
Ctrl+S keyboard shortcut.

4.4 Designing the User Interface

You can create a user interface by adding the toolbox controls to the design
form. This interface accepts connection information from the user.
To add toolbox controls:

Stepl: From the View menu, select Designer.
This opens Form1, in design view, if it is not already open.

You will toggle between Code and Designer a lot. The keyboard shortcuts are
F7 and shift- F7 respectively.

Step2: From the View menu, select Toolbox.
Step3: In the Toolbox, expand Common Controls.

+ all Windows For... ~

k Paointer
Button
CheckBox

8. CheckedListBox
=% ComboBox

T DateTimeRicker
A Label

A LinkLabel

=. ListBox

337 ListWiew

#-| MaskedTextBox

] MonthCalendar

Step4: In the Toolbox, select Label, and drag it onto the Form1.

19



Forml.cs* - Forml.cs [Design]* |~ skart Page - X

8 Form1

Step5: On Formi, right-click label1l.

-
Form1

[Z] view Code
{Q; Ering to Front
414 send to Back
5|

@ Lock Controls

Select 'Form1'

Cut

Copy

Delete

i§ % [& & o<

Properties

Step6: From the menu, select Properties, if the Properties Window is not
already visible.

The Properties Window appears.

Step7: In the Properties Window, change the Text property from labell to
User ID.
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Properties

labell Zvystem.Windows.Fo =
=
Tag

User ID
Textalign ToplLeft
UseCompsz False
UseMnemec True

UsewaitCL False

Wisible True ot

L)

Text

The text associated with the
contral,

Step8: Repeat steps 4 through 7 three times, placing three more labels on
Form 1 and changing their text properties to Password, Server and
Database.

Formi

LR?r I Pazzword Server

Step9: In the Toolbox, select TextBox, and drag it onto the Form1, under the
User ID label.

Form |Z| |E| [$__<|

Uszer D Pagsword Server Database

Step10: In the Properties Window, change the Name property to userID.
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textBoxl Swstem.Window -

[Applicatio ~
{DataBindi

ETNEYES userID
AcceptsRe False
AcceptsTa False
Accessible

Accessible W

Step11: Repeat steps 9 and 10 three times, positioning three more text boxes
under the existing labels, and setting the Name property to password,
server and dataSource.

Form1 g@gl

User 1D Password Server Database

Step12: Select the text box under the Password label. In the Properties
Window, scroll to the PasswordChar property and set it to an asterisk (*).

This masks the password during entry.

password Svstem.Winc -~

MaximumSize 0,0
MaxLength 32767

Minimumsize 0, 0
Maodifiers Privat

Mulkiling False
PasswordChar

ReadOnly False

Step13: From the Toolbox, select Button and drag it onto Form1.

In the Properties Window, change the Text property of the button from
buttonl1 to Connect, and change the Name property to connect.
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Form1

Usger ID Pagsword Server Database

Step14: Save.
Step15: Close the Toolbox

Showe Mavigation

4.5 Writing the Connection Code

Now we write the code that takes the information provided to the user interface and
connects to the database.

To connect to the database, you must create a connection object.
To write code that connects to the database:

These steps enable your application to connect to the database based on data
that the user enters into the Form1 control. See Compiling and Running the

Application.
From the View menu, select Code.

Stepl: Add the code indicated to instantiate a database connection string.

Visual C#: Add the class variable conn to the Form1 class right after the
public Forml () block with this code.

private RdbConnection conn = new RdbConnection();
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Forml.cs*| Forml.cs [Design]* | Start Page -

“T4 PERS_Connect_C3.Forml W || g conn

2 ||| %

Eusing System:
using 3ystem.Collections.Generic;
using 3ystem.ComponentModel;
using 3Iystem.Data;
using 3ystem.Drawing;
using 3Iystem.Text:
using 3ystem.Windows.Forms:
using Cracle.Datalccess.RdbClient;

E namespace PERS_Connect C3
{

public partial class Forml @ Form

{
public Forml()
{

InitializeComponent () ;

i
private RdbConnection conn = new RdbConnectionf() :|

Visual Basic: Add the conn class variable in the Form1 class declaration,
using this code.

Public Cclass Forml
Dim conn As New RdbConnection

Forml.vb*| Formil.wb [Design]® Skart Page
“t% Form1 + | |[Ed(peclarations)
Imports QOracle.Databocess.RdbClient
F Public Class Forml

L Dim conn As New RdbConnection
End Class

Step2: Save your changes.

Step3: Change to Designer view by clicking on the View menu and selecting
Designer.

Step4: Double-click the Connect button on Form1 to open the code window
to the connect Click () method.

Insert the code indicated into the connect Click () method.

Visual C#:

conn.ConnectionString = "User Id=" + userID.Text +
";pwd=" + password.Text +
";server=" + server.Text +
";database=" + database.Text +
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";type=Thin;";

conn.Open () ;

Visual Basic:

conn.ConnectionString = "User Id=" + userID.Text & _
";pwd=" + password.Text & _
":database=" + database.Text & _
";type=Thin;"

conn.open()

Visual Basic Imports statements, at or near the top of a code file.

Before a connection can be opened, it must be built from user input for the
User Id, pwd, server,and database.
The Open () method makes the actual connection.

Step5: Setthe Enabled attribute of the button to false by inserting the
indicated code at the end of the connect Click () method.

This disables the Connect button, which is a good practice once a
connection is successfully made.

Visual C#:

connect.Enabled = false;

Forml.cs*| Start Page -

“% PERS_Connect_CS.Forml || 5% connect_Click{object sender, Eventargs &)

» || [*

using Systewm.Draving:
using System. Texc;
using System.Windows.Forms;
using Oracle.Datalccess.RdbClient;

E namespace PERF Connect C5

{
public Forml()
{

{
i public partial cless Formi : Form

InitislizecConponent (] -
}

private RibConnection conn = new RdbConnection () ;

=] private void connect_Click{ohject sender, Eventirus e)
{

conn. ConnectionScring = "User Id=" + userID.Text +
":pud=" + password.Text +
";server=" + server.Text +
"idatshase=" + datsbase.Text +
":type=Thin:":

conn. Open (] ;
connect.Enabled = fal=e;
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Visual Basic:

connect.Enabled = false

Form1.vb*| Formi.vb [Design]* |  Formé.cs [Design] | Formd.cs [Desian] | Forml.cs [Design] o
[ (General) + | [fZl(pedlarations)

Dim conn As Mew RdbConnection

= Priwvate Sub Buttonl Click(By¥al sender Ls Jystem.Object, EyVal & As System.Eventirgs

conn.Connectiondtring = "User Id=" + userID.Text & _
Tipwd=" + password.Text £ _

"rdatabase=" + datsbhase.Text & _
”It,vpe=Th1n; "

conn.Openi)
connect.Enabled = False
End Sub
“End Class

You have now finished writing an application that can connect to the Oracle
Rdb database.

The following sections show how to use it.

4.6 Compiling and Running the Application

This section shows how to compile and run the application you created in the
previous sections.

To compile and run the application:

Stepl: From the Build menu, select Build Solution.

Build [~ Debug Data Tools  ‘Window
Build Solution F&

Reebuild Solution
Clean Solution
|ﬁ| Build PERS_Connect_WB  Shift+F&
Rebuild PERS_Connect_VE
Clean PERS_Conneck_YE
Publish PERS_Connect_VE

Configuration Manager...

Step2: Ensure that there are no errors reported in the output window,
available from the View menu.

The following graphics shows a typical output result.

j Compile complete —— 0 errors, 0 warnings
PERS_Connect_CS -> C:\PERS_Projects\PERS_Connect_ CS\PERS_ Connect_CS\bin\Debug\PERS_Connect_CS.exe
========== Rebuild Al11: 1 succeeded, 0 failed, 0 skipped ==========
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Step3: If there are any errors indicated, from the View menu, select Error
List and fix the errors.

Step4: From the Debug menu, select Start Without Debugging to run the
application.

Debug | Data Tools  Window  Communit

Windows 3
 Start Debugging F5
[+ Start Without Debuaging Chrl+F5
:-—‘A Attach ko Process. ..

Exceptions.. . Chrl+D, E
5= sStep Inko F11
[ stepover F10

Toggle Breakpaint Fa

Mew Breakpaoint b

Step5: In the Form1 application, enter the User ID, Password , Server, and
Database.

Click Connect.

Once the connection is opened, the Connect button is disabled. You have
succeeded in implementing a connection to an Oracle Rdb Database.

Form1

Uszer D Password Server D atabase
““““““““““ S055erver GEMERIC uzer]:[dbs]ml_personnel

Fidbnst_user

4.7 Error Handling
Applications must be able to handle run-time errors gracefully. For example, if
you try to log in using an incorrect password, the application you developed
so far cannot establish a connection to the database, and exits with the
following unhandled exception
%RDB-E-AUTH_FAIL: authentication failed for user

You must reselect Start Without Debugging to try this with a different
password.
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Error handling manages occurrences of conditions that change the normal
flow of program execution. Oracle Rdb Data Provider for .NET contains a
single classes for error handling and support:

o« The RdbException class represents an exception that is thrown when the
Oracle Rdb Data Provider for .NET encounters an error. Each
RdbException object contains a description and an error number that
describes the error or warning.

4.7.1 Using Try-Catch-Finally Block Structure

.NET languages use Try-Catch-Finally block structure for error handling. With
this structure, the Try code is the main code, the goal that the application
wants to accomplish. The Catch code catches errors of various types, as
shown in the next two section. The Finally block comes last and always
executes.

The Finally block frequently contains the Dispose method, which closes and
disposes of the connection. Having the Di spose method in the Finally block
ensures that the database connection is always closed after the Try-Catch-
Finally block completes. Closing database connections after the application no
longer requires database access is important for many reasons, especially data
security.

Attempting to close a closed database connection does not cause an error.
The attempt is irrelevant. Nonetheless, placing Dispose () in the Finally
code block guarantees that the connection is closed.

The next section shows how to use Try-Catch-Finally block structure with
general errors, and the section after that, with Oracle Rdb errors.

4.7.2 Handling General Errors

This section shows how to handle general errors using a Try-Catch-Finally
block.

To handle general errors:

Stepl: Change the code of the connect Click () method in Forml by
adding an implementation of the Try-Catch-Finally syntax.

New code is in bold font.
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Visual C#:

private void connect_Click(object sender, EventArgs e)

conn.ConnectionString = "User Id=" + userID.Text +
";pwd=" + password.Text +

";server=" + server.Text +

";database=" + database.Text +
";type=Thin;";conn.Open () ;

try

{

conn.open();
connect.Enabled = false;

catch (Exception ex)
MessageBox.Show(ex.Message.ToString());
Eina11y
conn.Dispose();
}
Alternatively, you can use C# syntax that disposes of a connection when it
goes out of scope, with the using keyword, as follows:
using (RdbConnection conn = new RdbConnection())

conn.open();
// application code

}

Visual Basic:

Try
conn.open()
connect.Enabled = false

Catch ex As Exception ]
MessageBox.Show(ex.Message.ToString())

Finally
conn.Dispose()
End Try

Step2: From the Build menu, select Rebuild Solution.
Ensure that there are no errors.

Step3: From the Debug menu, select Start Without Debugging.
Step4: Run the application again, as described in section Compiling and

Running the Application, and attempt to connect using an incorrect password.
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Show Mavigation |

This time, the application catches the error and displays it in a pop-up
window, %RDB-E-AUTH_FAIL: authentication failed for user.

Failed to connect : in <idbjdbczreconmect failures
ERDE-E-AUTH_FAIL, authenbcation failed for wser muray

(b, Client. <idle.
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Chapter 5 Retrieving and Updating with
ORDP.NET

This chapter contains:

Using the Command Object

Retrieving Data: a Simple Query

Retrieving Data: Bind Variables

Retrieving Data: Multiple Values

Using the DataSet Class with Oracle Rdb Data Provider for .NET
Enabling Updates to the Database

5.1 Using the Command Object

To view, edit, insert or delete data in a database, you must encapsulate a
request in an RdbCommand object specifying a SQL command, stored
procedure, or table name. The RdbCommand object creates the request,
sends it to the database, and returns the result.

To use the command object:

Stepl: Make two copies of Forml . xx, from application PERS_Connect_xx in

Building a Simple .NET Application Using ORDP.NET. To make copies, see the
instructions in Copying a Form.

Name the copies Form2.cs or Form2.vb and Form3.cs or Form3.vb.
The first copy is for the first part of the chapter, and the second copy for the
second part of the chapter

Step2: Open Form2.cs or Form2.vb.

Note that the actual form in the designer still says Form1, as you renamed
code files but not the actual form controls within the project.

Step3: Create a string that represents the SQL query and add to the body of
the try statement.

The new code is in bold typeface.

Visual C#:
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{

conn.open();

connect.Enabled = false;

// SQL Statement

string sql = "select department_name from departments"
) + " where department_code = ‘ENG’";

Visual Basic:

Try
conn.open()
connect.Enabled = False

Dim sql As String = "select department_name from departments" &

"where department_code = ‘ENG’"

Step4: Use the new sgl variable to create the RdbCommand object, and set
the CommandType property to run a text command.

Visual C#:

try

{
conn.open();
connect.Enabled = false;

// SQL Statement
string sql = "select department_name from departments"

+ where department_code = ‘ENG’";

Rdbcommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;
Visual Basic:

Try
conn.open()
connect.Enabled = False

Dim sql As String = "select department_name from departments" &
"where department_code = ‘ENG’"

Dim cmd As New RdbCommand(sqgl, conn)
cmd.CommandType = CommandType.Text

Step5: Save your work.

5.2 Retrieving Data: a Simple Query

This section demonstrates retrieving data from the database.
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The ExecuteReader () method of an RdbCommand object returns an

RdbDataReader object, which can be accessed to display the result on the
form. The application uses a ListBox to display the results.

To

Step1l:

the

retrieve data:

bottom of the Try block of the connect_Click () method.

This enables you to read the result of the query.

The new code is in bold typeface

Visual C#:

try
{

}

conn.open();
connect.Enabled = false;

// SQL Statement
string sql = "select department_name from departments™

+ where department_code = ‘ENG’";

RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;

RdbDataReader dr = cmd.ExecuteReader();
dr.Read(Q);

Visual Basic:

Try

Step2:
Step3:

conn.open()
connect.Enabled = False

Dim sql As String = "select department_name from departments" &

"where department_code = ‘ENG’"

Dim cmd As New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text

Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read()

Create an RdbDataReader object, by adding the code indicated to

Open Form1 in Design view. From the View menu, select Designer.

From the View menu, select Toolbox.
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Step4: From the Toolbox, select a Label and drag it onto Form1.

Step5: From the View menu, select Properties Window.

Step6: In the Properties window, change the Text of the label to
Department.

Step7: From the Toolbox, under Window forms, select a ListBox and drag it
onto Forml.

Step8: In the Properties window, under Design, change the Name to
departments.

Uzer ID Password Server D atabase

departments

Step9: Add accessor type methods for retrieving data from the query result.

Double-click the connect button to edit the connect click () method,
and add the code indicated to the bottom of the t ry block.

Visual C#:
departments.Items.Add(dr.GetString(0));

Visual Basic:

departments.Items.Add(dr.GetString(0))

Typed accessors, such as GetString, return native .NET data types and
native Oracle Rdb data types. Zero-based ordinals passed to the accessors
specify which column in the result set to return.

The try block should look like this now:

Visual C#:

try

conn.open();
connect.Enabled = false;
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// SQL Statement
string sql = "select department_name from departments™

+ " where department_code = ‘ENG’";

RdbCommand cmd = new RdbCommand(sql, conn);
cmd.CommandType = CommandType.Text;

RdbDataReader dr = cmd.ExecuteReader();
dr.Read();

departments.Items.Add(dr.GetString(0));
ks

Visual Basic:

Try
conn.open()
connect.Enabled = False

Dim sql As String = "select department_name from departments" &
"where department_code = ‘ENG’"

Dim cmd As New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text

Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read(Q

departments.Items.Add(dr.GetString(0))

Step10: Build and save the application.
Stepl1: Run the application. Enter the login server and database information.

After you connect, the departments list box shows Engineering, the
correct name for department with code ' ENG’ in the Departments table, as
requested by the SELECT statement.

| & rorm1 EEX
%ar 1D Paszword Server Database
Rdbnet_user | e S055erverGENERIC uzerl:[dbs]mf_personnel
Department

Engineering
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5.3 Retrieving Data: Bind Variables

Bind variables are placeholders inside a SQL statement.

The following code shows a typical SELECT statement that does not use bind
variables, with the value 10 specified in the WHERE clause of the statement.

SELECT department_name FROM departments WHERE department_code = ‘ENG’

The following code replaces the numerical value with a bind variable
:department id. A bind variable identifier always begins with a single

colon ( :).

SELECT department_name FROM departments WHERE department_code =
:department_id

Note that bind variables can also be used with UPDATE, INSERT, and
DELETE statements, and also with stored procedures. The following code
illustrates how to use bind variables in an UPDATE statement:

UPDATE departments SET department_name = :department_name
WHERE departname_code = : department_id

You can use the RdbParameter class to represent each bind variable in
your .NET code. The RdbParameterCollection class contains the
RdbParameter objects associated with the RdbCommand object for each
statement. The RdbCommand class passes your SQL statement to the
database and returns the results to your application.

To retrieve data using bind variables:

Stepl: Move the ListBox named Departments to the right.

Step2: From the View menu, select Toolbox.

Step3: From the Toolbox, select a TextBox and drag it onto Form1, under the
label that says Department.

Step4: From the View menu, select Properties Window.

Step5: In the Properties window, change Name to departmentID.
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Step6: Change the SELECT statement to use the bind variable by adding the
code indicated to the Try block of the connect Click () method.

Changed or new code is in bold typeface.

Visual C#:
string sql = "select department_name from departments "+
"where department_code = :department_id";

RdbCommand cmd = new RdbCommand(sql, conn);

cmd.CommandType = CommandType.Text;

RdbParameter p_department_id = new RdbParameter("department_id",
DbType.String);

p_department_id.value = departmentID.Text;
cmd.Parameters.Add(p_department_id);

RdbDataReader dr = cmd.ExecuteReader();
dr.Read();

departments.Items.Add(dr.GetString(0));

Visual Basic:
Dim sql As String = "select department_name from departments " & _
"where department_code = :department_id"

Dim cmd As RdbCommand = New RdbCommand(sql, conn)
cmd.CommandType = CommandType.Text

Dim p_department_id as RdbParameter = new
RdbParameter(“department_id”, DbType.String)

p_department_id.value = departmentID.Text
cmd. Parameters.Add(p_department_id)

Dim dr As RdbDataReader = cmd.ExecuteReader()
dr.Read()

departments.Items.Add(dr.GetString(0))

For this code, the parameter object sets the DbType property, but there is no
need to set the Direction property because it uses the default value,
Input. There is no need to set the Size property because the object is an
input parameter, and the data provider can determine the size from the value.

Step7: Save and run the application.

Step8: Enter the login information, and a typical department code, such as
“"MNFG”, from the MF_PERSONNEL database.

Step9: Click Connect.

The application returns the name of the department that corresponds to the
department ID.
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User 1D Pazsword Server Database
Rdbnet_user | |FEess S055erver GENERIC userl:[dbz]mf_Personnel

MMFG M anufacturing

5.4 Retrieving Data: Multiple Values

You frequently need to retrieve more than just one value from the database. A
DataReader object can retrieve values for multiple columns and multiple
rows. Consider the multiple column, multiple row query in the following
example:

SELECT department_code, department_name, manager_id FROM
departments
WHERE department_code < ‘ENG’

Processing multiple rows from the DataReader object requires a looping
construct. Also, a control that can display multiple rows is useful. Because the
RdbDataReader object is a forward-only, read-only cursor, it cannot be
bound to an updatable or backward scrollable control such as Windows Forms
DataGrid control. An RdbDataReader object is, however, compatible

with a ListBox control.
To retrieve multiple values:

Stepl: Inthe try block of the connect Click () method, change the SQL
query to return a multiple row result set and add a while loop to enclose the
read method that displays the department names.

Visual C#:
try

st%%ﬁg sql = "select department_name from departments +
"where department_code < :department_id";
"%hi1e (dr.Read())

departments.Items.Add(dr.GetString(0));
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Visual Basic:

Try

Dim sql As string = "select department_name from departments " & _
"where department_code < :department_id"

"‘while (dr.rRead())
departments.Items.Add(dr.GetString(0))
End whiTle

Step2: Save and run the application.
Step3: Enter the login information and enter "ENG” for the department.
Step4: Click Connect.

The application returns the name of the departments that correspond to the
query.

Form1 g@@

Uzer D Password Server Database
Rdbret_uger | [T S055erver GEMERIC uzer]:[dbz]mf_Personnel

EMG Corporate Administration
Electronics Engineering
Large Systems Engineering
Mechanical Enginesring

5.5 Using the DataSet Class with Oracle Rdb Data Provider
for .NET

The DataSet class provides a memory-resident copy of database data. It
consists of one or more tables that store relational or XML data. Unlike an
RdbDataReader object, a DataSet is updatable and backward scrollable.

To use the DataSet class:

Stepl: If you have not done so before, make another copy of the Form1 that
you completed in Chapter 3, and name it Form3.vb or .cs, as described in
Copying a Form

Step2: If Forml.xx does not appear in the Solution Explorer, from the
Project menu, select Show All Files.

Step3: From the View menu, select Designer view.

Step4: From the View menu, select Toolbox.

Step5: From the Toolbox, select a DataGridView and drag it onto Form1.
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Step6: From the View menu, select Properties Window.
Step7: In the Properties window, change the Name of the data grid view to
departments.

Form1 g@@

User ID. Password _ Sewver Database

Step8: From the View menu, select Code.
Step9: Immediately after the conn declaration in the code, add variable
declarations to the class variables, as indicated.

Visual C#:

public partial class Forml : Form
?ub1ic Forml1()
InitializeComponent();

private RdbConnection conn = new RdbConnection();
private RdbCommand cmd;

private RdbDataAdapter da;

private RdbCommandBuilder cb;

private DataSet ds;

Visual Basic:

Public Class Forml
Dim conn As New RdbConnection
Private cmd As RdbCommand
Private da As RdbDataAdapter
Private cb As RdbCommandBuilder
Private ds As DataSet

Step10: Within the connect Click () method try block, add code to:
o Query the database
o Fill the DataSet with the result of the command query
o Bind the DataSet to the data grid (departments)

Visual C#:



conn.open();

connect.Enabled = false;

string sql = "select * from departments where "+
"department_id < ‘ENG’";

cmd = new RdbCommand(sql, conn);

cmd.CommandType = CommandType.Text;

da = new RdbDataAdapter(cmd);
cb = new RdbCommandBuilder(da);
ds = new DataSet();

da.Fill(ds);

departments.DataSource = ds.Tables[0];

Visual Basic:

conn.open()

connect.Enabled = False

Dim sql As String = "select * from departments where " + _
"department_id < ‘ENG’"

cmd = New RdbCommand(sqgl, conn)

cmd.CommandType = CommandType.Text

da = New RdbDataAdapter(cmd)
cb = New RdbCommandBuilder(da)
ds = New DataSet()

da.Fill1(ds)

departments.DataSource = ds.Tables(0)

Step11: Build and save the application.
Step12: Run the application, entering the login and data source.

After you successfully connect to the database, the data grid is populated with
the results of the query.

Form1

Uszer Il Pagsword Server Databaze

Rdbret_user | | SQ55erverGEMERIC ugerl:[dbglmi_Perzonnel
DEPARTMEMT ... DEPARTMEMT_... @ MANAGER_ID

» ADMMN Corporate Admi,,., 00225

ELEL Electronics Engin,,. 00158
ELGS Large Svstems E... 00363
ELMC Mechanical Engi,.. 00190
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5.6 Enabling Updates to the Database

At this point, the DataSet contains a client copy of the database data. In
this section, you will add a button that enables client data changes to be
saved back to the database. The following section will show you how to test
updating, inserting, and deleting the data.

To enable saving data from the DataSet to the database:

Stepl: From the Toolbox, drag and drop a Button onto Form1.
Step2: In the Properties window, change the Name of the button to save.

Change the Text property to Save.
Step3: At the top of the Properties Window, click Events (the lightning bolt). In

the list of events, select the click event. In the second column, enter the event
name, save Click.

Form1

UseriD . Password _ Server Datsbase

0
&
<
@

Step4: From the View menu, select Code.
Step5: Add code that updates the data, to the body of the save Click()
method, as indicated.

Visual C#:

da.update(ds.Tables[0]);

Visual Basic:

da.update(ds.Tables(0))

You may see some errors show up in the Error List. These will disappear after
you add the code in the next step.

Step6: Within the Form () method or Forml Load method, add the code
indicated.
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Visual C#:

gub]ic Forml1()

InitializeComponent();
save.Enabled = false;

Visual Basic:

Private Sub Forml_Load(Byval sender As System.Object, & _
Byval e As System.EventArgs) Handles MyBase.Load
save.Enabled = false

Step7: Within the connect Click () method try block, add code to
enable the Save button as indicated:

Visual C#:

conn.open();

débértments.DataSource ds.Tables[0];

save.Enabled = true;

Visual Basic:

conn.open()

departments.DataSource ds.TabTles(0)

save.Enabled = True

Step8: Remove the conn.Dispose () call from the finally block in the
connect Click () method.

Note: In the previous code used in this example, this method was necessary
to dispose or close the connection. However, with these changes to the code,
it is necessary to keep the connection open after the query result returns, so
that data changes made by the end user are propagated to the database. A
general override call, components.Dispose (), is already part of the
definition of Form1.

Step9: Build and save the application.
Step10: Run the application, entering the login and data source.

After you successfully connect to the database, the data grid is populated with
the results of the query.
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Showe Mawvigation |

Uszer ID Pasaword Server Database
Relbnet_user | [= 505SemerGENERIC | |userl:[dbsimf_Personnel
JDEPARTMENT_,.. DEPARTMENT ... | MANAGER_ID
3 ADMM Corporate Admi... 00225
.F_I.EL Electronics Engin... 00158
.EI.GS Large Syskems E... 00369
:EI.MC Mechanical Engi,.. 00190
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Chapter 6 ORDP.NET and Visual Studio
Wizards

In this section you will use the Visual Studio integrated development
environment (IDE), along with the standard Visual Studio wizards to
automatically generate the code to access data from your Rdb database

This chapter contains:

Create a New application

Add connection to RDB database in MS server explorer
Create a datasource for the employees table

Design the windows application

6.1 Create a New application

Create a new windows application using the File >New - project menu.
Call it empapp.

See Creating a New Project for the steps to create a new project.

6.2 Add connection to RDB database in MS server explorer

See Connecting to the Oracle Rdb Database for steps to connect to your
database.

6.3 Create a datasource for the employees table
To create a new Data Source:

Stepl: Using the top-level menu Data - Add New Data Source.
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@9 EmpApp - Microsoft Visual Studio

File Edit WView Project Build Debug | Data | Tools Test Window Community Help

gﬂ R - | [ y [ _j Show Data Sources  Shift+Alt+D Ay cpu
at | | . || oo s | =G | ] Add New Data Source... |
= 5 = T RN
E
MNew Quer
¥ Server Explorer >0 x A Query
o .
g_" ] N | Close Connection
g = LJ-J Data Connections Modify Connection...

[E™user 1:[murray]mf_personng I

T4 Servers

Step2: In the wizard, keep the default selection for “Database.” Click Next

Step3: From the list of connection, select the connection to the sample that
was created that was created earlier, select the option to include the sensitive
data in connection string. Click Next

Step4: Check to save the connection string to the Application Configuration
File Click Next

Data Source Configuration Wizard @
;éj_) Choose Your Data Connection
‘Which data connection should your lication use to to the datat 7
|usar1:[murray]mfjersonnal b | [ Mew Connection...

This connection string appears to contain sensitive data {for example, a password), which is required to
connect to the database. However, storing sensitive data in the connection string can be a security risk. Do
you want to indude this sensitive data in the connection string?
() Mo, exclude sensitive data from the connection string. I will set this information in my application code.
(®) Yes, indude sensitive data in the connection string.

Connection string

[ < Previous ” MNext > ]

Step5: A tree of available table will be displayed, select the employees table
from the list of tables by checking the box next to it. Click finish
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Data Source Configuration Wizard

| J:F) Choose Your Database Objects

Which database objects do you want in your dataset?

13 0¥P_IN_PROCESS_PALLET

[T pzR_DORMANT IN_PROCESS_REEL
[ emp

[ empivFo

>

[¥] 3 eMPLOYEES
[1E3 Foes
[0 maces L
[[1E3 10B_HISTORY

[ 108s

(1 MANAGER._COMMENTS
[1E3 myTaBLE

13 FIcTURE

[1E3 PRODUCTTAB

|13

DataSet name:
[EmpDataset1 |

Step6: A data source for employees will be added in the “"Data Sources”
window.
You can make the data source window visible using the top level menu
Data > Show Data sources

@9 EmpApp - Microsoft Visual Studio

File Edit View Project Buld Debug Data Tools Test Window Community Help

[ RNEE R =" W= B EENE =N 4 - B - 5| P Debug ~ Any CPU
|2 & ol |0 o s |22 3] i o | e i H [+] | T3 9 | =
Data Sources -~ 0 x Form1l.cs [Design] | StartPage
e ig g
g3 G :
g B [o¥] EmpDataSet1 E® Form
& G IR v '
ADDRESS_DATA_1
ADDRESS_DATA_2
T BIRTHDAY
CITY

EMPLOYEE_ID
FIRST_MAME
LAST_NAME
MIDDLE_IMITIAL
POSTAL_CODE
SEX

STATE
STATUS_CODE

6.4 Design the windows application

Stepl: Ensure that From1l.cs is open in design mode.



..... @ app.contig

= |50l EmpDataSet1.xsd
b % EmpDataSet1.Designer
- %] EmpDataSetl.xsc
. ] EmpDataSetl.xss
|j Cpen
"""" Open With. ..

View Code

| View Designer

e;?; View Class Diagram

Excude From Project
Step2:

window onto the form.

P4 4 o of {0} | b M |42 %

Drag and Drop the Employees data source from the data sources

‘ ADDRESS_DATA_| ADDRESS_DATA_| BIRTHDAY CITY EMPLOYEE_ID FIRST_NAME

LAST_NAME

MIDDLE_INITY

*

I ]

2% empDataSet1 237 eMPLOYEESBindingSource 5], eMPLOYEESTableAdapter 7 eMPLOYEESBindingNavigator

Step3: Run the windows application
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Showe Mawvigation |

P4t of 102 | b bl |k X (A

ADDRESS_DATA_| ADDRESS_DATA_ BIRTHDAY cITy EMPLOYEE_ID FIRST_NAME LAST_NAME MIDDLE_IN #
W /201947 Choconuz 00154 Avin Toliver A 3

120 Tenby Dr. B5/15/1954 Choconua 00165 Temy Smith D

18 Union Square 3/20/1954 Boscawen 00166 Rick Dietrich

143 Pine 5t 3/5/1937 Marlow 00167 Janet Kilpatrick

87 West Rd. 10/23/1932 Meadows 00168 Noman Nash

51 Maple St. 8/13/1938 Eina 00169 Susan Gray (9]

140 Searles Rd. ... 6/3/1957 Jefferson 007 Brian Wood

67 Underhill 5t 1/29/1932 Sandown 00171 Aruwa DrAmico )
< il | >
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Chapter 7 ORDP.NET and drag and drop

In this section you will use the Visual Studio integrated development
environment (IDE), along with drag and drop to automatically generate the
code to access data from your Rdb database.

This chapter contains:

Create a New application

Add connection to RDB database in MS server explorer
Add a new Typed DataSet

Designing the windows application

Running the windows application

7.1 Create a New application

Create a new windows application using the File > New - project menu.
Call it empapp.

See Creating a New Project for the steps to create a new project.

7.2 Add connection to RDB database in MS server explorer

See Connecting to the Oracle Rdb Database for steps to connect to your
database if you do not already have a connection.

7.3 Add a new Typed DataSet

To add a new Typed DataSet to your project:
Step1: Run the windows application

Using the Microsoft Solution Explorer, right click on the EmpApp, and select
Add > New Item
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SRSl SOILToN EXplorer - EmpA - o
B F S
[ Solution 'EmpApp’ (1 project)
(SRR
=¥ Build
Rebuild
Clean
=
Publish...
Run Code Analysis
| New Item... Il add S
ol Cusimbimn Them Add Rafarancs

Step2: Select DataSet. Click Add. The Microsoft Dataset Designer will be opened.

Add New Item - EmpApp ; |
Templates: |E|

Visual Studio installed templates A

#] Class ;& Interface #] Code File

=] Windows Form ] User Control ] Custom Contral

[E]Inherited Form | Inherited User Control jﬂWeh Custom Control

.-1%] Companent Class lJ S0L Database DataSet|

2] XML File |Z]¥ML Schema P ¥SLT File

@] HTML Page A Style sheet =] TextFie

|4 Bitmap File By | cursor File 5] Report

\}JCrystaI Report j Icon File r,%] Windaws Service

o] Installer Class 51 35cript File 3 ]VBScript File

5] Windows Script Host ] Assembly Information File ] Application Configuration Fil —

:_:.‘aResources File _] Settings File QMDI Parent

=2] About Box E Debugger Visualizer ‘% Class Diagram

v
A DataSet for using data in your application

Name: Datasetl.xsd

From the Microsoft Server Explorer, drag and drop “Employees” table onto the

open designer.

This will create a datasource and an associated EMPLOYEESTableAdapter

that can you use in your application to access the employees table.

ADDRESS_DATA_1
ADDRESS_DATA_2
BIRTHDAY
CITY
EMPLOYEE_ID

# FIRST_NAME
LAST_NAME

? MIDDLE_INITIAL

# POSTAL_CODE

¥ OSEX
STATE

¥ STATUS_CODE

¥ EMPLOYEESTableAdapter

Fill, GetData ()

B
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Step3: Ensure the password is added to the connection string. Select
EMPLOYEESTableAdapter, and right click to view its properties. Append the
password in the below format Password=yourpassword

EMPLOYEESTableAdapter TableAdapter

B Code Generation

BaseClass System. ComponentModel. Camponer
ConnectionModifier Internal
Modifier Public
MName EMPLOYEESTableAdapter
Bl Data
El Connection ConnectionString (Settings)
Mame Connectionstring (Settings)
Modifier Internal
server=tezuka.us.oracle.comp
DeleteCommand (Mone)

7.4 Designing the windows application
To design the application:
Step1: Ensure the Forml.cs is open in design mode.

Step2: Using the Microsoft data sources window, use the smart menu on the
Employees data source, and select Details

@9 EmpApp - Microsoft Visual Studio

File Edit View Project Build Debug Data Tools Test Window Community Help

ENREE RN | L EEN = - =, | b Debug - Any CPU
. - p
UL = & ST ok al [ g = )
>35 Data Sources > 3 X DataSetl.xsd* ' Form2.cs [Design] [ Start Page
HFFE
g || 2 (o7 Dataset1 5'59'_ B|EIEI

=9 EmF DataGridview
=] Detais |

S [Mone]

Customize. ..

Step3: Drag and drop the Employees data source from the data source window
onto the form.
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Form2

P 4 o of {03 | b b |5k X [

ADDRESS DATA T: |
ADDRESS DATA2: |

BIRTHDAY: | Tuesday , October 21, 2008 A

CITY:

EMPLOYEE ID:

FIRST NAME:

LAST NAME:

POSTAL CODE:

SEX:

STATE:

STATUS CODE:

|
|
|
|
MIDDLE INITIAL: |
|
|
|
|

A prototype form to access the employees data will be created for you.

7.5 Running the windows application

Run the application using the top-level menu. You can insert, delete rows and
change the existing data.

Form2 Q@

P 4|7 of02 | b M | X [

ADDRESS DATA1: [140 Searles Rd
ADDRESS DATAZ: |

BIRTHDAY. | Monday . June 03,1357 &
CITY: |Jefferson

EMPLOYEEID: 00170

FIRST NAME [Brian

LAST NAME: [Wood

MIDDLE INITIAL: |

POSTALCODE:  |03583
SEX. [m
STATE: [NH
STATUSCODE: |1

Showe Mawvigation |
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Chapter 8 Configuration wizard and
generating queries

Wizards make it easy to perform many operations within Visual studio. The
Table Adapter Query Configuration Wizard simplifies the creation of queries
you may execute on your Rdb database.

This chapter contains:
e Using the Query Configuration Wizard

e Using the Query Builder
e Methods Generation

8.1 Using the Query Configuration Wizard
To use the Query Configuration Wizard:

Stepl: Right click dataset and click add->Query

ADDRESS_DATA_1 Add Pl query..
ADDRESS_DATA_2 Configure... T2 Relation...
BIRTHDAY
Ccut 7 Key...
cITY & ?
EMPLOYEE_ID =3 copy Column
? FIRST_NAME

The Table Adapter Query Configuration Wizard will be shown.

54



TableAdapter Query Configuration Wizard

Choose a Command Type ndE=
{md
TableAdapter query uses 5QL statements or a stored procedure. <= :

How should the TableAdapter query access the database?
(%) Use SQL statements
Specify a SELECT statement to load data.

() Use existing stored procedure

Choose an existing stored procedure.

Step2: Select Use SQL Statement
Clicking Next will bring up the query Type window. This window allows you to

choose from several types of standard SQL statements.

TableAdapter Query Configuration Wizard

Choose a Query Type |
Choose thetype of query to be generated i

What type of 5QL query would you like to use?
(5) SELECT which returns rows
Returns one or many rows or columns.
() SELECT which returns a single value
Returns a single value (for example, Sum, Count, or any other aggregate function).

() UPDATE

Changes existing data in a table.
() DELETE

Removes rows from a table,
() INSERT

Adds a new row to a table.

[ < Previous ” Mext = I

Step3: Select the query type SELECT which returns rows.

Step4: Click Next to bring up the query specification window. This is where you
may enter a SQL query statement.. Use the ™:” character pre-pended to
parameter names to specify parameters you wish to use.
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TableAdapter Query Configuration Wizard

Specify a SQL SELECT statement & |
The SELECT statement will be used by the query. | — i

Type your SQL statement or use the Query Builder to construct it. What data should be loaded into the table?
What data should the table load?

SELECT CITY, FIRST_NAME FROM EMPLOYEES WHERE EMPLOYEE_ID=@EMPLOYEE_ID

Query Builder...

< Previous ” MNext = ]l Finish ][ Cancel ]

For example to return details of an employee giving the employee_ id:

SELECT CITY, FIRST NAME FROM EMPLOYEES WHERE EMPLOYEE ID=:EMPLOYEE ID

Step5: Click Finish. We have just added a select functionality to the typed
dataset using TableAdapter without writing a single line of code.

Repeat the above steps to produce other statements such as UPDATE and
DELETE .

8.2 Using the Query Builder

Visual Studio provides the Query Builder option within the configuration

Wizard that allows quick and easy creation of syntactically correct SQL queries
on your datasets.

Using Query Builder to generate queries:

Step1: Click Query Builder to bring up the builder window .
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Tables | views |

BIGTABLE
CANDIDATES

CBM_RESULT

COLLEGES

DATE_TIME

DEGREES

DEPARTMENTS

DOI_ORDER_ITEM
DYP_IN_PROCESS_PALLET
DZR_DORMANT_IN_PROCESS_REEL
EMP

EMPINFO

EMPLOYEES

FLD&S

3

B

[ Refresh ] [ Add l [ Close

]

Step2: Select EMPLOYEE table and click ADD. This will bring up a window

allowing you to choose columns for your query .

Query Builder ?[x]

& EMPLOYEES [_ |

* (Al Columns)
[_|ADDRESS_DATA_1
[ |ADDRESS DATA 2
[ |eRTHDAY
[erry

El

Column Alias Table Qutput | Sort Type
4 =
=

< |

SELECT
FROM EMPLOYEES

Execute Query

-~

~

Filter #

Sort Order
e

Step3: Click “Close” on ADD Table window to close this window.
Step4: Within the EMPLOYEES table check the columns name and

Parameters to the query (Filter) as shown below.
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Query Builder

= EMPLOYEES

ADDRESS_DATA_2
IRTHDAY
Iy
MPLOYEE_ID
TRST_MAME

Colu Quiput | Sort Type Sort Order Filter or.. ~
cImY
FIRST_NAME
3 EMPLOYEE_ID —'gEMPLOY... |
=
=
= L
=
= v

<

ISELECT  CITY, FIRST_NAME, EMPLOYEE_ID
FROM EMPLOYEES
\WHERE EMPLOYEE_ID =@EMPLOYEE_ID

|s

|~
|

Step5: Click Execute Query to execute the generated query. The results of
the operation will be displayed in the results window.

Query Builder

A~
= EMPLOYEES _| ]
EMPLOYEE_ID
[¥]FIRST NaVE ~|
M
51/ m) 3
Colu Output | Sort Type Sort Order Filter or... )
cIy
FIRST_NAME
3 EMPLOYEE_ID = 00164
[=
=
E L
=
[ L
8 .|
SELECT  CITY, FIRST_NAME, EMPLOYEE_ID
FROM  EMPLOYEES
WHERE  (EMPLOYEE_ID = 00164)
CITY FIRST_NAME EMPLOYEE_ID )
» Alvin 00164 8
* ALLL MLLL AL M
1 ofl [ b Bl M




Step6: Click "OK" to accept the query .

TableAdapter Query Configuration Wizard

Specify a SQL SELECT statement A |
The SELECT statement will be used by the query. |' — i

Type your SQL statement or use the Query Builder to construct it. What data should be loaded into the table?
What data should the table load?

SELECT  CITY, FIRST_MAME, EMPLOYEE_ID
FROM EMPLOYEES
WHERE EMPLOYEE_ID = @ EMPLOYEE_ID

Query Builder...

[<Previ0us ” MNext = ][ Finish ][ Cancel ]

Step7: Click “"Finish”. Your query is now ready to use. The Query
Configuration Wizard will now display the Methods Generation window.

8.3 Methods Generation

Once you have generated a query, this query may be used within the
TableAdapter . The next step is to choose what methods should be available
within your TableAdapter.

How to choose methods:

TableAdapter Query Configuration Wizard

Choose Methods to Generate Y
The Tablefdapter methods load and save data between your application and the |‘ - i
database.

Which methods do you want to add to the TableAdapter?
Fill a DataTable

Creates a method that takes a DataTable or DataSet as a parameter and executes the SQL statement or
SELECT stored procedure entered on the previous page.

Method name: |FillBy
Return a DataTable

Creates a method that returns a new DataTable filed with the results of the SQL statement or SELECT stored
procedure entered on the previous page.

Method name: | GetDataBy_ELR0]

[ < Previous ][ Mext > ][ Finish }[ Cancel ]

Stepl: Select the Fill A DataTable and Return a DataTable .
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Step2: Change the Return a DataTable method name to
GetDataBy_EMPID

The final dataset in the designer show look like the following:

B EMPLOYEES

ADDRESS_DATA_1
ADDRESS_DATA_2
BIRTHDAY

oIy
EMPLOYEE_ID
FIRST_NAME
LAST_NAME
MIDDLE_INITIAL

]

i

POSTAL_CODE
7 osEx
STATE
? STATUS_CODE
&
[ Fill,GetData
2 FilBy,GetDataBy_EMPID (@EMPLOYEE _ID)

Step3: To execute the above functionality in your code, instantiate the table
adapter as follows:

DataSetlTableAdapters.EMPLOYEESTableAdapter adapt = new
DataSetlTableAdapters.EMPLOYEESTableAdapter () ;

This new select function can now also be seen in the TableAdapter
intellisense.

- 1
& Dispose A
¥ Disposed
i Egquals
i Fill
i FillBy
iy GetData
¥ ceatey Een M
iy GetHashCode
iy GetlifetimeService
W GetType w

Step4: The methods provide by the TableAdapter may be used within your code

/I Get Employee details by employee_id

dataGridViewl.DataSource=adapt.GetDataBy EMPID(00164) ;

Showe Mawvigation |
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Chapter 9 Copying a Form

Because you will be using this application to learn about various aspects of
application development with Oracle Rdb, you should make copies of your
form for reuse.

To create a copy of an existing form:

Stepl: In the Solution Explorer, right-click on Form1.xx or any other file you
need to copy. Select Copy.

If Forml.xx does not appear in the Solution Explorer, from the Project
menu, select Show All Files.

Solution Explorer - Salution 'HR_Application_CS' {1 project)

= £=| )

J Solution 'HR._application_C5' {1 project)
= (] HR_Connect_CS

+- |=d| Properties

+- [+3] References

.j‘ Open

Open With,..
& 0933 Wiew Class Diagram
Inchude In Project
4 Cut
53 Copy
>< Delete

Properties Rename

Forml.cs| .
izz) Properties
w= A1

Step2: Right-click HR_Connect_CS or other project. Select Paste.
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9

- -

a

Frope]
HR_C|

Poli
Prof

[ Solution 'HR_Application_CS' (1 pro
[l o oo oo I

Build
Rebuild
Clean
Publish...
Add

Add Reference..,
Add web Reference...
Yiew Class Diagram

Set as StartUp Project

Debug
cut

Paste

Remave
Rename
Unload Project

Properties

Step3:

the form to Form2. cs.

Solution Explorer - Solution 'HR_Application_CS' {

(0B B B

Properties

—

Right-click Copy of Forml . cs. Select Rename. Change the name of

B

Copy of Form1 [El

'_: Solution 'HR_Application_C5' {1 project)
= _E HR_Connect_CS

=d| Properties

3] References

Open

Open With, ..

Wiews Class Diagram
Include In Project
Cut

Copy
Delete

Rename

Properties

Step4:

Right-click on Form1 . cs, and select Include In Project.
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n Explorer - Solution 'HR._Applicatiol

=] £=| 2}

_: Solution 'HR_Application_CS' (1 praj
= [ HR_Connect_CS
- |=d| Propetties
#- .= References
#- .3 bin
- (2 obj
= j Forml.cs
EE] Forml Designer.cs
‘-g] Formi resx
A

J Qpen
Open With. ..

09;; View Class Diagram

Include In Project

& Cur

Properties | .
B S Copy

Form2.cs >< Delete

: : 9 l‘ Rename

Custom

= Propetties
Cuskom =

Step5: Right-click on Forml . cs, and select Exclude From Project.

Showe Mawvigation |

You can include and exclude forms from the project just by reversing these
steps.

Note:

This process generally works smoothly. If you encounter a problem, try
running Rebuild Solution from the Build menu.
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Chapter 10 Oracle Rdb Entity Framework
Provider

The Entity Framework is a new part of ADO.NET that allows you to build your
applications against conceptual data models. It provides a greater level of
abstraction and supports code that is independent of any particular relational
database.

It provides an Entity Data Model (EDM) for defining data at the database and
conceptual level and mapping between the two. It includes a nice set of tools
that can be used to generate the EDM and corresponding objects that
represent the database. This eliminates much of the required boilerplate data
access code, and makes it a snap to create data-centric applications.

The chapter also provides some simple examples on how to carry out Model-
First and Database-First application development using the Oracle Rdb Entity
Framework Provider.

Model-first is the ability to start with a conceptual model and create the
database from it. Database-first is the ability to start with the database and
build your EDM from the database objects.

This chapter contains:

Creating new Windows Form Application
Create a new Entity

Creating Complex Types

Generating Database Schema from Model

10.1 Creating new Windows Form Application
The first step is to create a new Windows Forms application:
Step1: In Visual Studio IDE, select File>New->Project from the main menu.

Choose the Windows Forms Application installed template. Click OK. The
solution is created.
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Step2: Right-click on Forml . cs and select Exclude From Project.

You can now proceed to generate a Entity Data Model from an existing
database schema.

10.1.1 Adding an Entity Data Model
How to add an Entity Data Model:
Step1: In the Solution Explorer, right-click your application and select Add->
New Item. This opens Visual Studio installed templates screen.

Step2: From Visual Studio installed templates, select ADO.NET Entity
Data Model. Click Add.

Add New Item - WindowsFormsApplication (@]
Installed Templates Sort byt | Default sl = o
= Visual C# Ttems ~
Type: Visual C# Items
] Closs visual C# lkems "
— A project item For creating an ADOWNET Entity
& Data Model.
| ﬁ Interface Wisual C# Ttems
Ci
—— | windows Form visual C# Items
ﬂ User Control visual C# Items
.ﬁ Component Class Visuel C# Ttems
- User Contral (WPF) Visual C# Teems.
| AbourBex Visual C# Teems.
Qj ADO.NET Entity Data Model wisual C# Ttems
% ADO.NET EntityObject Generator wisual C# Ttems
% ADONET Self-Tracking Entity Generator Visual C# Ttems.
Application Canfiguration File Visual C# Tkems
B,|  Appiication Marifest Fie Visusl C# Tretns
C'*E Assembly Information File: Wisual C# Ttems.
e
W stmanFie Visual C# Trems
(=] - vt 9
Mame: Model1.edmx

. R

You will now see the Entity Data Model Wizard. This wizard is used to
generate the Entity Data Model from the database specified in the database
connection string ( in next step).

Step3: Select the icon Generate from database. Click Next.



Entity Data Model Wizard

_ Choose Model Contents
~ /]
o=

What should the model contain?

Generates the model from a database. Classes are generated from the model when the project is

compiled. This wizard also lets you specify the database connection and database objects to include
in the madel,

Step4: You can now select the connection if you have made connection to the

test database earlier or create a new connection:

Entity Data Model Wizard

_ Choose Your Data Connection
~ |
==

Which data connection should your application uze to connect to the database?

This connection string appears to contain sensitive data (For example, a password) that is required to

connect ko the database, Storing sensitive data in the connection string can be a security risk, Do you
want ko include this sensitive data in the connection string?

O Noc,I exclude sensitive data from the connection skring. I will sek it in my application
code,

(%) Yes, include the sensitive data in the connection string.
Ertity connection skring:
metadata=res:/*Modelz.csdl|res: [ (*Model 2 ssdl |res: §* Model2. msl; provider=0racle. Datafcce
55, RdbClient; provider connection

string="server=localhost:1701; database=e:\regtestimf_personnel;server bype=THIN;buffer
size=5000;user id=murray"

Save entity connection settings in App.Config as;

Entities

< Previous ” Mext = ]

e__regkest_mf_personnelConnectionString (Settings) w

If you have not already done so, you can create the new connection at this
time by clicking New Connection. See Connecting to the Oracle Rdb

Database for details on each fields shown in New Connection Form.
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Step5: Click Next

The Entity Data Model Wizard connects to the database. You are then
presented with a tree structure of the database.

Here you can select the object you would like to include in your model
Here we have choosen to select all tables, just as a part of example.
But, You have a option to select any specific table.

Step6: Check the box against Tables node.

Entity Data Model Wizard @E|
J_ _ Choose Your Database Objects
—S==

Which database objects do you want ta include in ywour madel?
= M
[#] 0 Cons (MULL)
[ CustomersDb (MULL)
[ views
[ % stared Procedures

Fluralize or singularize generated object names
Include Foreign key columns in the model
Model Mamespace:

Model

l [ Cancel

Step7: Click Finish to create the model and exit the wizard.

Visual Studio will generate the model then display it.
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WindowsFormsApplication1 - Microsoft Visual Studio

Fle Edt View Project Buld Debug Team Data Tooks Test Window telp

RS E = - IR RECREN S RS SRS R N e ~| <86 || % | writetySaype - g e |

10.1.2 Adding a new Data Source

You will now add a new Data Source to your project and see how it can be
used to read and write to the database.

To add a new Data source:

Stepl: From the Visual Studio Main Menu, select Data> Add New Data
Source.

You will be presented with the Data Source Configuration Wizard.

Data Source Configuration Wizard

JJ_) Choose a Data Source Type

Where will the application get data from?

J &

Database Service

34

SharePaint

Lets yvou choose objects that can later be used to generate data-bound contrals,




Step2: Select the Object icon. Click Next.
Step3: You will now select the Object you wish to bind to. Expand the tree.

In this tutorial we have choosen Con table as a example. Once the Con table
has been selected click Finish.

Data Source Configuration Wizard

Select the Data Objects
]
=

Expand the referenced assemblies and namespaces to seleck vour objects, IF an object is missing from a
referenced assembly, cancel the wizard and rebuild the project: that contains the object.

What objects do you want to bind to?

ENOlEs] vindowsFormsapplicationt
= [B] {} windowsFormsapplicationl
“% Con
(1%t cCustomersDb

[C1%% Entities
1% Form1
F “% Program
14} windowsFormsapplication1, Properties

Hide system assemblies

Finish ] [ Cancel

The Con object will be displayed in the Data Sources panel. If the Data

Sources panel is not displayed, select Data->Show Data Sources from the
Visual Studio Main Menu.

The docked panel will then be displayed.

M = customersdb v
1 A cons
bl Customerld

abl| Firstname
abl] Ppsn
i sbl| Surname
B = 4 Entities
%% Cons
“%; CustomersDbs
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10.1.3 Using the Data Source in a Windows Form

To use the Data Source:

Step1: In the Data Sources panel, select the Data Source you just created and
drag and drop it onto the Form Designer.

By default the Data Source object will be added as a Data Grid View
control.

Note: the Data Grid View control is bound to the consBindingSource and
the Navigator control is bound to consBindingNavigator.

R

- 0|

b X

nnnn

Step2: Save and rebuild the solution before continuing.

10.1.4 Adding Code to Populate the Data Grid View

You are now ready to add code to ensure that the Data Grid View control will
be populated with data from the Con database table.

How to add code to Populate the view:
Step1l: Double-click the form to access its code.

Step2: Add code to instantiate the Entity Data Model's EntityContainer object
and retrieve data from the database to populate the control.
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WindowsFormsApplication1 - Microsoft Visual Studio

Flle Edit View Refactor Project Buld Debug Team Data Tools Test  Window Help

SR R ™ = NI RN NI B SR RN A - [xz8 s [+
iDRhoefFlE==2 003 b8 0 .

ﬂ Formi.cs 3¢ [l it e Form1.cs [Design]
Ln

‘%3WindﬂwsFﬂrmsApDhtat\DnlFnrml - 3VFﬂrm17Lﬂad(ﬂhiatt sendet, Eve
“lusing System:
using Jystem.Collections.Generic:
using System.ComponentModel;
using System.Datar

= using Jystew. Draving:
‘E_;_ using System.Ling:
g using System.Text:

using System. Tindows.Forms;

~namespace WindowsFormsipplicationl
{
= public partial class Forml @ Form
{
Entities we:
= public Formi()
1
InitializeCowponent ()
H

= private void Forml_Load{chject sender, Eventlrgs e)
1

we = new Entities();
consBindingSource. Datafource = we.Cons;

Step3: Save and rebuild the solution.

Step4: Run the solution. Ensure the grid is populated and you can navigate
through the data.

Form1

L of3| b bl |4 K

ConHigtld ConzType Consv'ear
22 pl 1230
23 pl 1230

10.2 Create a new Entity

A new Entity Data model can be created from scratch by using the Entity Data
Model Designer.
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How to create an Entity Data Model:

Step1: In the Solution Explorer, right-click your application and select Add->

New Item.

Step2: From Visual Studio installed templates, select ADO.NET Entity Data

Model. Click Add.

T r—— @3]

Installed Templates Sortby: [Dofaut [ 2|
= Visual C# tems -~
Type: Visual C# Items
Coce o] s Visus! C# Teems s
Data = A praject item for creating an ADQ,HET Entty
2, Data Madel,
General Zod] Interface Wisual C# Trems
cf
weh
Wirdons Forms —=| windows Form wisual C# Trems
WPF
\ﬂ User Control visual C# Trems
@ Component Class Wisual C# Trems
®1| user Control (wPF) ¥isual C# Items
S| AbotBox Wisual C# Trems
Gy ADONET Bty Data Model wisual C# Items
Qo 4DONET EntiyCbject Generstor Wisual C# Trems
o, ADONET Sal-Tracking Enity Generator wisual C# Items
B Application Configuration File Visual C# Trems
B,|  Apiication Marifest Fils wisual C# Trems
C'*E Assembly Information File Wisual C# Ttems
e
Bitmap Fils visual C# Trems
[ERR— i
Nlame: Model1.edmc

You will now see the Entity Data Model Wizard. This wizard is used to generate the
Entity Data Model from the database specified in the database connection string

Step3: Select the icon Entity model. Click Finish.

Entity Data Model Wizard

~ Choose Model Contents
< ]
==

What should the model contain?

Generate from [y
database

Creates an empty model as a starting point: for visually designing a conceptual model From the
toolbox, Classes are generated from the model when the project is compiled. ou can specify a
database connection later ko map the conceptual model ko the storage model,

Finish ] [ Cancel
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An empty Entity Data Model Designer Form should now be displayed.

Model3.edmy ~ Modell edmx | Program.cs | Start Page B

The Entity Data Model Designer lets you visualize and design your Entity Data Madel,

Create new entities in the model by dragging items From the Toolhox.

We will now show how to design a following sample entity:

“#42 Emp_Table E3
=| Properties
#HEmp_1d

ff‘Last_Name
f;‘First_Name
o Title

= Mavigation Properties

Step4: Add a new Entity by right-clicking in the Model Designer and selecting
Add-> Entity.

Model3.edmx | Modell .edmex | Program.cs | Start Page

Add

=

[§1tity. m

Diagram

Zoam

Grid Function Import...

r v v -

Scalar Property Format

(ﬁj Mapping Details
\._'.‘] Model Browser
Update Model from Database.. .

Walidate

iz Properties 5 vou visualize and design your Entity Data Model,

Create new entities in the model by dragging items from the Toolbosx,
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The Add Entity form will be displayed.

Add Entity

Properties
E ity name
E ritity 1
Base type:
[Mane]

Enlity Set:
Entity1Set

F.ey Property
Create key property
Property name;

Id

Property type:
Int32

BX

v

Step5: Change the Entity name to Emp Table and the Key Property name

to Emp_id. The Entity Set will be automatically changed to Emp TableSet

Kep Property
Create key property
Property name:

Emp_Jd

Property type:
Int32

0K I [ Cancel

Step6: press OK.
Step7: Right-click the new entity and use Add > Scalar Property to add three

more String properties Last name, First name and Title

Model3.edmn™® ~ Modell.edmx | Program.cs | Start Page

&2 Emp_Table

a

i = Scalar Properties
i B¥Emp_1d

{| (=l Navigation Props

X W

Add

Rename

Cut

Copy

Delete

Collapse

Table Mapping

Stored Procedure Mapping

Show in Model Brawser

Update Model from Database. ..

Validate

Properties

Scalar Property

[%ssnciatinn.. .

Funikion Import,..
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Remember to change the Properties > Type for each of the new properties
to String by selecting the respective scalar properties.

Properties

Model3.Emp_Table.Last_Name Froperty -
% Emp_Table = o= A ]

E= (£
Concurrency Mode Mone
= Scalar Properties Default Yalue
Dacumnentation

?ﬁEI‘I‘Ip_Id Entity Key False
i Getter Fublic
= Mavigation Properties Mame Last_Name
HMullable True
Setter % Public
String v

10.3 Creating Complex Types

Complex types are non-scalar properties of entity types which enable scalar
properties to be organized within entities. This makes easier to work with
objects, allowing the grouping of related properties in Entities.

As an example, let us create the Complex type Employee Name instead of
the Last Name and First Name properties.

To create a Complex type:

Stepl: Hold the CRTL key and Select the properties in the data model that
you want to group together
Step2: Right click in the context menu, select Refactor into New Complex

Type

&2 Emp_Table B

= Properties

#¥Emp_1d
=

)

i Title Refactor into Kew Complex Type
=l Mavigation Propertie

% cut Crl
Sa opy ke
4 Pasts Chry
X Delste Del

Update Model from Database. .,

Generate Database from Model...

Add Code Generation Ttem...

validats !

= Propetties Ale+Enter
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The model browser will display a new Complex Type.

Mode Browser

= |4 Model3.edmx
= &) Modela
# [ Entity Types
= [ Complex Types
# % | ComplexTypel
| ] Associations

7 (4] EntityCantainer: Model3Co
= | J Model3.Store
[ Tables [ views
[ Stored Procedures
[ Constraints

Step3: Now let's give a more meaningful name. If you expand the Complex

Typel, you will see the properties that we previously selected. Change the
name from ComplexTypel t0 Employee Name.

Model Browser

= & Model3.edmx
= |&] Model3
+ [J Entity Types
= [3 Complex Types
= & Eear
7 First_Name
_“f‘ Last_Name
| Associations

+ @ EntityContainer: Model3Container
= | J| Model3.5tore

+ [ Tables [ Views
[£3 Stored Procedures
[ Constraints

If you look at your data model you will see that ComplexProperty has been
added to the list.

“2 Emp_Table £

= Properties
#5Emp_1d
FTitle
S ComplexProperty
= Mavigation Properties
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Step4: Change the name from ComplexProperty to Emp Name.

2 Emp_Table =

=| Properties
FeEmp_1d
5 Title

B Emp_Mame
=| Mavigation Properties

If you look at the properties, you will see that the type of Emp_Name is the
complex type name that is Employee_Name which we just created.

Muodel3.Emp_Table.Emp_Name Property
=)
=]
Getker Public
Setter Public
=]
Concurrency Mode Mone
Docurmentation
Mame Emp_Name
Type Employee_Name

10.3.1 Using the Complex Type created

The Complex type you created may be used as follows:
Step1: In Visual Studio, select File>New->Project from the main menu.

Choose the Console Application installed template. Click OK. The solution is
created.

Step2: Design a new Entity with Complex Types. See Create a new Entity ,
Creating Complex Types

Step3: Generate the Database schema from the data model you have designed.
See Generating Database Schema from Model

The Console Application’s solution explorer looks as follows:
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Solution Explorer

=2 zZEa
3 Solution 'Consalefpplications’ {1 project)
=] _E ConsoleApplicationd
=d| Propetties
=i References
_:. App.Config
& Model3,edm:x
557 Model3.edrm. sql

Step4: Open Program.cs file by double clicking on it.
Step5: Write the code to use the complex type just created.

% ConsoleApplications. Program v| 4 Main(string[] args)
“lusing Svstem:
using 3ystem.Collections.Generic:
using System.Ling:
using System. Text:

-Insmespace Consolelpplications
1
= class Program
1
= static void Main(string[] args)
{

using (var context = new Model3Container())
{

Ewp_Tsole tab = new Emp_Table(]:
teb.Emp_Name.Last_Name = "John";
tab. Emp_Neme.| "king:
taR.TiElE = 7§ Eguas

COoncexc. RddTDﬁ First_Name

COntext. 3avec & GetHashCode

W GetType
5 Last_Marme

¥ PropertyChanged
¥ PropertyChanging
3 W ToString

Step6: The Complete code looks as follows.



% ConsoleApplicationd, Program -| 2% Mainstringl] args)
uszing System.Text:

—nsmwespace Consolelpplicationd
{
= class Program
{
= static void Main(string[] args)
{

using (var context = newy ModeliContainer ()]
{

Emp Table tab = new Emp Tshlei):

tab.Emp_Neme.Last_Neme = "John";
tab.Emp Name,First Nawe = "king":
tab.Title = "Engineer™;

context. AddToEmp_Table (tab) ;
context.3aveChanges ()}

var newCourse = from ¢ in context.Emp Table where o.Emp Name.Last Name == "John" select co;

foreach (Emp_Tsble db in newCourse)

4
Console.Uriteline ("Employee ID ={0}", db.Emp_Id);
Console.Writeline ("Ewployee First MName={0}:", db.Ewmp Newe.First Name)
Console.Wriceline ("Employee Designation ={0}", dh.Ticle):

Step7: Save and rebuild the solution. See Compiling and Running the

Application
Step8: Run the solution and we get following output on Console.

AWINDOWS\system32icmd.exe

Employee ID =321

[Employee First Mame=king
Employee Designation =Engineer
[Press any key to continue . . .

10.4 Generating Database Schema from Model

Visual Studio 2010 with Entity Framework V2.0 enables you to generate a
database schema from an existing Data Entity Model.
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This section will take you through the steps required to generate a fresh
database schema definition from a model.

How to generate a schema from an Entity Data Model:
Step1: From the Properties window of your selected data model choose

SSDLToOracleRdb.tt in the DDLGeneration Template property as shown
below:

L‘.T;‘ Solution Explorer ﬁ‘ Team Explarer Rti\as HAl

Properties * 0 X
Model3 ConceptualEntityMadel -
= A
CE A l
ode Generation Strategy Default -~
Lazy Loading Enabled True
=]
Metadata Artifact Processing Embed in Qutput Assembly
=
Database Generation WarkFlow TablePer Typestrategy . xaml (¥3)
Database Schema Mame dba

DOL Generation Template SSDLToOracleRdb.tt (¥S) v
SSDLT0SQLI0.EE (¥S)
55 cleRdb .tk (vs)

Entity Container Access
Entity Container Mame
Mamespace Model3

Fluralize New Objects True e

DDL Generation Template
The T4 text template used to transform SSOL ta DOL in the Generate Database wizard,

Step2: Right click on entity designer and select Generate Database from
model

%2 Emp_Table 2

= Properties
¥emp_1d
P Title
“HEmp_Name

= Navigation Properties

Add
Diagram
Zoom
arid

Scalar Froperty Format

select All

Iapping Details

B &y

Model Erowser

Updats Model From Database...
Generate Database from Modsl, ..
Add Code Generation Ttem. ..
validate

‘= Propertiss Alt+Enter

Step3: Add a Connection to the database when prompted.
Step4: Click Next. A new SQL script will be generated .
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Generate Database Wizard @

| jl:l_) summary and Settings

Save DOL As: |M0del3.edmx.sql

ool |

-- Creating all tables

-- Creating table "Emp_Table"

CREATE TABLE "Erp_Table" {
"Emp_Id" AUTOMATIC IMNSERT AS CAST(Emp_Table_IDEMTITY . MEXTWAL AS INTEGER)
PRIMARY KEY,
"Title" MCHAR YARYING(Z000) , =
"ComplexProperty_First_Mame" NCHAR VARYING{2000) ,
"ComplexProperty_Last_Mame" NCHAR VARYING{Z2000)
b

-- Creating all indexes providing access ko PRIMARY KEYs

[ Finish ][ Cancel ]

You can now copy the SQL script create and execute on your Rdb database using

Interactive SQL.

Show Mavigation
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Chapter 11 Unsupported features

°
°
°
[ ]
[ ]
Showe Mawvigation |

Foreign Key support

Open Table definition

Alter Procedure

Data View Designer
Import/export table data as XML.

Glossary

assembly
Assembly is Microsoft's term for the module that is created when a DLL or .EXE is
complied by a .NET compiler.

Binary Large Object (BLOB)
A large object datatype who's content consists of binary data. Additionally, this data is considered raw
as its structure is not recognized by the database.

Character Large Object (CLOB)
The LOB datatype whose value is composed of character data corresponding to the database character
set.

data provider
As the term is used with Rdb Data Provider for .NET, a data provider is the connected component in the
ADO.NET model and transfers data between a data source and the DataSet.

dirty writes
Dirty writes means writing uncommitted or dirty data.

DDL
DDL refers to data definition language, which includes statements defining or changing data structure.

DOM

Document Object Model (DOM) is an application program interface (API) for HTML and XML
documents. It defines the logical structure of documents and the way that a document is accessed and
manipulated.

flush
Flush or flushing refers to recording changes (that is, sending modified data) to the database.

instantiate
A term used in object-based languages such as C# to refer to the creation of an object of a specific class.
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Large Object (LOB)
The class of SQL datatype that is further divided into internal LOBs and external LOBs. Internal LOBs
include BLOBS, CLOBS, and NCLOBs while external LOBs include BFILES.

Microsoft .NET Framework Class Library
The Microsoft .NET Framework Class Library provides the classes for the .NET
framework model.

namespace
. NET:

A namespace is naming device for grouping related types. More than one
namespace can be contained in an assembly.

. XML Documents:

A namespace describes a set of related element names or attributes within an
XML document.

National Character Large Object (NCLOB)
The LOB datatype whose value is composed of character data corresponding to the
database national character set.

octet
An 8-bit unit, usually referred to as BYTE

RdbDataReader
An RdbDataReader isa read-only, forward-only result set.

primary key
The column or set of columns included in the definition of a table's PRIMARY KEY constraint.

reference semantics
Reference semantics indicates that assignment is to a reference (an address such as a pointer) rather
than to a value. See value semantics.

result set
The output of a SQL query, consisting of one or more rows of data.

savepoint
A point in the workspace to which operations can be rolled back.

stored procedure
A stored procedure is a block of SQL code that Rdb stores in the database and can be
executed from an application.

Unicode
Unicode is a universal encoded character set that enables information from any language to be stored
using a single character set.

URL
URL (Universal Resource Locator).
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value semantics
Value semantics indicates that assignment copies the value, not the reference or address (such as a pointer). See
reference semantics.

Showe Mawvigation |
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